Back to overview
Resolved
All of the Texas Alert Service is down.
Sep 1, 2026 at 1:39am UTC
Affected services
texasalertservice.com
Resolved
Sep 1, 2026 at 1:39am UTC
The server has been wiped, and we are actively working to fix it! (All data has been lost)
Affected services